Sharepoint 2010 Character problem in Category Titles in Blog Site for different languages

Hello Everyone,

If you faced a character problem in Category Titles in Blog Site Template for different language , may be this article helps you. In my envoriment i am using Turkish Language Pack (1055) .
the repro is not tested on other languages but it  should be occurs for other languages which is contains specific characters .

I think this  problem is a minor bug .You can reproduce it easily .

Here the Repro steps.
1) Install or find SPS2010 + SP1Dec2011 CU + TR(1055) language pack installed machine.
2) Create a site collection in Turkish
3) Create a “Web Günlüğü”  (Blog Site Instance)
4) Add some categories that contains Turkish Characters.
5) Click one of this category titles in left navigation  and open category page

I have created a category named : “Yağlı Boya Seçmeleri”  You can see the problem bellowed screenshot.

The problem is when rendering left panel Categories web part (XSTLListView) not encode url of Link object correctly. I have tested with changing the link in browser’s address bar with correct encoding the titiles shown correctly on category page.

So There  is a workaround for fixing this issue with using Sharepoint Designer 2010 .

1) Open defauılt aspx and (any needed page) in Sharepoint Designer.

2) Select one of the link  in Categories  XsltListViewWebpart


3) Click the HyperLinkOptions button.

4) Change the default value of
{$HttpVDir}/{$thisNode/../@resource.wss.lists_Folder}/{$thisNode/../@resource.wss.blogcategories_Folder}/Category.aspx?CategoryId={$thisNode/@ID}&Name={$CategoryTitle} as
{$HttpVDir}/{$thisNode/../@resource.wss.lists_Folder}/{$thisNode/../@resource.wss.blogcategories_Folder}/Category.aspx?CategoryId={$thisNode/@ID}&Name={$thisNode/@Title}

5) Repeat same options for all needed pages.

And Open and Check  again your blog page :

(For who know Turkish the word of “Şeçme” have a little typo correct word is “Seçme” . Dont worry about it . i am not get all screenshot again for fixing this 🙂

See you next article.

Advertisements

What is the difference of Server.HtmlEncode and HttpUtility.HtmlEncode

There is no diffrence just Server.HtmlEncode calls  HttpUtility.HtmlEncode.
if you use reflector you realise that server object is kind of Httputility.

For more info:
http://msdn.microsoft.com/en-us/library/ms525347.aspx
http://msdn.microsoft.com/en-us/library/system.web.httputility.htmlencode.aspx