Decommisioning Microsoft Sync Framework 1.0 SP1 runtime


Microsoft Sync Framework 1.0 SP1 runtime is one of the prerequists for SharePoint Server 2013/2016/2019 installations.
https://docs.microsoft.com/en-us/sharepoint/install/hardware-and-software-requirements-2019

SharePoint 2019 is the last version of SharePoint that will have still dependency on the Sync Framework.  It’s used to support Groove client syncing, which was deprecated for SharePoint 2019 in favor of the OneDrive sync client.But the dependancy still present for backward compatibility.

Unfortunately the support for Microsoft Sync Framework 1.0 SP1 runtime was end of life in January 2019. https://support.microsoft.com/en-us/lifecycle/search/14459

Specifically, the customers are asking: Microsoft Sync framework v1.0 SP1 is the minimum pre-requisite for SharePoint 2019. Customer wants to know if Microsoft Sync Framework v2.1 is supported for SharePoint 2019?
Our product group is working on this scenario, This is something we can not answer quickly that we need to do lots of tests and make some decision based on these tests. So we do not suggest upgrade yet.
SharePoint customers should stick with the Microsoft Sync Framework 1.0 SP1 runtime. (28th of March,2019)

Microsoft SharePoint Product group verifies under SharePoint setup and installation concept, Microsoft Sync Framework 1.0 SP1 runtime will be still supported for SharePoint Server 2013/2016/2019 installations.(28th of March,2019)
(But if you use Microsoft Sync Framework 1.0 SP1 runtime outside SharePoint with your project or tools or standalone it won’t be supportable anymore)

Advertisements

About bpostaci
Escalation Engineer in Microsoft.

Comments are closed.

%d bloggers like this: